Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Required: 0.9 requirements expanded)
 
(25 intermediate revisions by 16 users not shown)
Line 1: Line 1:
In order to run {{Fail2ban}}, you need:
+
== Required ==
  
* [http://www.python.org Python] >=2.3
+
The only required dependency needed to run {{Fail2ban}} is [http://www.python.org Python]. You need:
* [http://sourceforge.net/projects/log4py Log4py] (not needed with >=fail2ban-0.5.2)
+
  
You may also need:
+
* 0.9 branch
 +
** [http://www.python.org Python] >=2.6, [http://www.python.org Python] >=3.2, [http://pypy.org PyPy]
 +
 
 +
* 0.8 branch (>=0.8.2)
 +
** [http://www.python.org Python] >=2.4
 +
 
 +
* 0.8 branch (<0.8.2)
 +
** [http://www.python.org Python] >=2.3
 +
 
 +
* 0.6 branch
 +
** [http://www.python.org Python] >=2.3
 +
 
 +
Since 0.8.2, we set the minimal requirement back to [http://www.python.org Python] 2.3. Lots of rock-solid server distributions are still shipped with this version of [http://www.python.org Python].
 +
 
 +
== Optional ==
 +
 
 +
You may need some of these packages depending on your requirements:
  
 
* [http://www.netfilter.org/ Netfilter/Iptables]
 
* [http://www.netfilter.org/ Netfilter/Iptables]
 
* [http://www.shorewall.net/ Shorewall]
 
* [http://www.shorewall.net/ Shorewall]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 +
* a mailer script
 +
* ipset
  
 
[[Category:Fail2ban]]
 
[[Category:Fail2ban]]

Latest revision as of 03:02, 15 March 2014

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (>=0.8.2)
  • 0.8 branch (<0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: